2012-01-30

Hyper-V och blådumpar när man installerar... ("Stop 0x0000007E")

Hittade en "kul feature" idag när det gäller Hyper-V.
Det hela uppstod när jag skulle installera Microsoft Hyper-V server 2008 R2. (alltså gratisvarianten av Hyper-V. Den som ser ut som Windows 2008 R2 Core edition).

Vad som hände var att när servern bootade om för andra gången under installationen så såg allting jättebra ut, den hade packat upp alla filer under föregående omstart. Nu är tanken att den skall fortsätta installationen. De där gröna staplarna som åker från vänster till höger dyker upp och helt plötsligt en blåskärm!

Därefter så stor maskinen och bootade om i all oändlighet utan att komma vidare.

Jag testade så klart de vanliga sakerna (utan inbördes ordning)
- Verifiera att jag har de senaster firmwares och BIOS installerade (det hade jag).
- Att installationsmediat inte var trasigt
- Att det inte sitter nån konstig hårdvara i servern (typ extra nätverkskort, grafikkort eller SAN-HBA).
- Att hårdvaran ligger med på kompabilitets listan.

Alla dessa kontroller såg bra ut så jag testade så klart att installera om ett par gånger. Ingen skillnad.

Testade att installera vanliga Windows 2008 R2 Enterprise. Fungerade klockrent. Aktiverade Hyper-V rollen. Startade om => Blåskärm...

Efter lite pysslande så hittade jag denna artikel: http://support.microsoft.com/kb/974598
("You receive a "Stop 0x0000007E" error on the first restart after you enable Hyper-V on a Windows Server 2008 R2-based computer")
Där skriver man om att det finns en uppdatering man kan lägga in i windows och sedan så skall det funka.
Dock fungerar inte denna till Microsoft Hyper-V Server 2008 R2. Dessutom kommer jag inte in i Windows när jag kör Hyper-V server 2008 R2 eftersom att det är installationen som kraschar. :)

Så vad är då lösningen?
Jo att gå in i BIOS på maskinen och disabla alla C-states (allihopa!).
Det går utmärkt att köra processorn som i strömspar osv. Men just C-states skall vara disablade.
Därefter installera Microsoft Hyper-V server 2008  R2 precis som vanligt.
*tada!!*

:)

En annan "kul" grej är att efter att jag har installerat allting och det är uppe och snurrar som det skall så kan jag gå in i BIOS och aktivera C-states igen.. Då får jag blådumpar precis som tidigare. :)

1 kommentar:

  1. Hänger det ihop med det här?
    http://www.hardwaresecrets.com/article/Everything-You-Need-to-Know-About-the-CPU-C-States-Power-Saving-Modes/611/1
    Hypervisorn gillar mao inte att delar av processorn stängs av...eller är det instruktioner som den inte vet att hantera?

    /Skuggan

    SvaraRadera

Related Posts Plugin for WordPress, Blogger...