2011-09-18

Hur gör man för att installera Windows 8 Developer Preview på XenServer 5.6 SP2?

Jag liksom rätt många andra verkar ha haft problem med att installera Windows 8 preview i XenServer 5.6 SP2.
Om man skapar en ny VM och bootar på 64-bits ISO-filen så får man först "Loading files...", därefter kommer "Windows Developer Previwe" loggan upp, varefter den fina texten "Your computer needs to restart."
Hela felmeddelandet är:
  Your computer needs to restart.
  Please hold down the power button.
  Error Code: 0x0000001E
  Parameters
  0xFFFFFFFF80000003
  0xFFFFF80001BCD100
  0x0000000000000000
  0x0000000000000000

De exakta siffrorna under "Parameters" brukar skilja sig lite åt mellan olika installationer, men i stora drag stämmer det. :)

Om det är x64 ISO-filen som används så bootar sedan maskinen om i all oändlighet och exakt samma felmeddelande upprepas varenda gång tills dess att man tvingar maskinen att stänga av sig.
Skulle det vara x86 ISO-filen som används så bootar maskinen om en gång och nästa gång så stannar den på felmeddelandet och stannar där tills dess att man tvingar maskinen att stänga av sig.

Kontentan är att installationen inte går vidare...

Så hur gör man??
Svaret har varit att använda XenServer 6.0, eller att installera i Hyper-V och därefter flytta över den virtuella maskinen till XenServer 5.6 SP2.
Men idag sprang jag på en sida som beskrev en alterntiv lösning som har fungerat för andra operativsystem...

Så jag testade i min labbmiljö hemma och här är hur jag gjorde:

1. Skapa en ny VM med utgångspunkt från Windows 7 64-bit templaten


2. Hitta på nått bra namn.. (jag valde "Windows 8 (64-bit)").
Vi använder detta namn lite senare.


3. Peka ut ISO-filen.


4. Lägg VMen på nån maskin (precis som vanligt ;))


5. Ge lite resurser.. Personligen så gillar jag att använda minst 2 vCPUer. Det blir liksom trevligare då. :)

6. Peka ut vart VMen skall ligga. Jag har bästa prestandan på lokalt storage så jag kör där för denna test.


7. Därefter är det dags för att peka ut vilket nätverkskort som skall användas.

8. Vi är framme vid sista steget i Wizarden, att verifiera att allting stämmer och här kommer första delen som skiljer sig från en helt vanlig installation.
Se till att klicka ut kryssrutan "Start the new VM automatically"


9. Det nu själva nyckeln för att få Windows 8 Developer Preview att funka i XenServer 5.6 SP2.
När maskinen sedan är skapad så starta en konsol på den XenServer som har VMen.
Nu behöver vi namnet vi skrev in i punkt 2.
Kör först kommandot: xe vm-list params=uuid name-label="Windows 8 (64-bit)"
Då får man UUIDn för den nyskapade maskinen.
Kör därefter kommandot: xe vm-param-set uuid={UUIDt vi fick i steget innan] platform:viridian=false
Så här såg det ut för mig:

10. Nu är det dags att starta VMen, och nu kommer den att starta precis som det är tänkt. *häpp*

11. Installera sedan precis som vanligt.


Extra tips:
Ett vanligt problem i Windows 8 är att man inte hittar avstängningsknappen.
Ett enkelt sätt är att trycka på ALT + F4 och sedan välja "Shutdown"... :)

Inga kommentarer:

Skicka en kommentar

Related Posts Plugin for WordPress, Blogger...